<!DOCTYPE html>
<html lang="en" dir="ltr">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="Business, Tourism,Features, News, prescott, Freedom Park, pierce county historical association, History, Eagles, United States" />
<meta property="news_keywords" content="Business, Tourism,Features, News, prescott, Freedom Park, pierce county historical association, History, Eagles, United States" />
<meta property="author" content="David Clarey" />
<meta property="description" content="Prescott&#039;s Dallas Eggers remembers relying on a handful of spots for a drink of water when he was a kid playing in the mid-&#039;60s. There was the baseball diamond,..." />
<meta property="article:published_time" content="2018-12-14T12:00:00-06:00" />
<meta property="article:publisher" content="https://www.facebook.com/pages/Pierce-County-Herald/138576996175305" />
<meta property="article:modified_time" content="2018-12-14T12:00:00-06:00" />
<meta property="fb:app_id" content="784035034956760" />
<meta property="image:alt" content="A drone shot from Dallas Eggers shows a birds-eye view of the Freedom Park and the Great River Road Visitor &amp; Learning Center in Prescott. Photo courtesy of Dallas Eggers. " />
<meta property="article:tag" content="Business, Tourism,Features, News, prescott, Freedom Park, pierce county historical association, History, Eagles, United States" />
<meta property="image:title" content="A drone shot from Dallas Eggers shows a birds-eye view of the Freedom Park and the Great River Road Visitor &amp; Learning Center in Prescott. Photo courtesy of Dallas Eggers. " />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="Prescott&#039;s Freedom Park turns 90 with celebration this weeke..." />
<meta property="og:url" content="https://www.piercecountyherald.com/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend" />
<meta property="twitter:image" content="https://www.piercecountyherald.com/sites/default/files/styles/16x9_430/public/1idSbYhZrFsR3mEME452tFtyKetCgtFYH.jpg?itok=xAhE--So" />
<meta property="twitter:url" content="https://www.piercecountyherald.com/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend" />
<meta property="twitter:description" content="Prescott&#039;s Dallas Eggers remembers relying on a handful of spots for a drink of water when he was a kid playing in the mid-&#039;60s. There was the baseball diamond, the cemetery and what was then known as Tourist Park, now Freedom Park, which was only three blocks from his house.&amp;quot;That was our playground,&amp;quot;..." />
<meta property="og:type" content="article" />
<meta property="og:title" content="Prescott&#039;s Freedom Park turns 90 with celebration this weeke..." />
<meta property="og:image" content="https://www.piercecountyherald.com/sites/default/files/styles/16x9_1240/public/1idSbYhZrFsR3mEME452tFtyKetCgtFYH.jpg?itok=epiaE48l" />
<meta property="og:description" content="Prescott&#039;s Dallas Eggers remembers relying on a handful of spots for a drink of water when he was a kid playing in the mid-&#039;60s. There was the baseball diamond, the cemetery and what was then known as Tourist Park, now Freedom Park, which was only three blocks from his house.&amp;quot;That was our playground,&amp;quot;..." />
<meta property="og:image:height" content="698" />
<meta property="og:image:width" content="1240" />
<link rel="shortcut icon" href="https://www.piercecountyherald.com/sites/all/themes/piercecountyherald_theme/favicon.ico" type="image/x-icon" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><link rel="apple-touch-icon" href="https://www.piercecountyherald.com/sites/all/themes/piercecountyherald_theme/images/touch-icon.png" type="image/png" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="canonical" href="/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend" />
<link rel="amphtml" href="https://www.piercecountyherald.com/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend?amp" />
<link rel="shortlink" href="/node/4541716" />
<!-- Global site tag (gtag.js) - Google Analytics -->
      <script async src="https://www.googletagmanager.com/gtag/js?id=UA-778232-78" />
</script><script>window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-778232-78');</script>
    <title>Prescott&#039;s Freedom Park turns 90 with celebration this weekend | Pierce County Herald</title>
    <link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_XndFiLsqSvm6UcX9CWfg9ukGFwmZJc8Wm1VKf-odRII.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_dn1Z7ijuixoG-wMmyYi-2wgXq6gNxLsgC7vdi2dJMWs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/css/article-slider.css?pjn6cr" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?pjn6cr" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/all/themes/piercecountyherald_theme/css/global-no-mqs.css?pjn6cr" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/all/themes/piercecountyherald_theme/css/global.css?pjn6cr" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="https://www.piercecountyherald.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_oTw2mccdSyi5Mu_UeNjwZZ2nsxd4cA8KM0jkogZEw68.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_qdYchoQ6U5cmg5dZ307qiUM03rDEOxZdegmqA8aPui8.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-22', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_EbeHsjfK-XIt1JoIKq6Gqj3s12axNUs10_e3yFVNaUw.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/modules/custom/fcc_advertising/prebid/jquery.lazyload.js?pjn6cr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        // Set Global Vars
        try {
          var dfp_keywords = "'Business','Tourism','Features','News','prescott','Freedom Park','pierce county historical association','History','Eagles','United States'";
          var zone = "piercecountyherald";
        } catch (e) {
          console.log('Error setting up global vars', e);
        }
        // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/modules/custom/fcc_advertising/prebid/prebid.min.js?pjn6cr"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/modules/custom/fcc_advertising/prebid/googletag-base-node.js?pjn6cr"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4541716 node-type-article domain-www-piercecountyherald-com context-business"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <!--<li class="last">
            <a href="/register" title="Register">Register</a>
          </li>-->
        </ul>
          </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class='menu'><li class='first leaf'><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li><li class='leaf'><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li><li class='leaf'><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li><li class='leaf'><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li><li class='leaf'><a href="classifieds" title="Classifieds">Classifieds</a></li><li class='leaf'><a href="https://www.searchmarketplaces.com/marketplace/piercecountyherald/" title="Marketplace: Pierce County Herald">Marketplace</a></li></ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Pierce County Herald"><img src="https://www.piercecountyherald.com/sites/all/themes/piercecountyherald_theme/logo.png" alt="Pierce County Herald" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Pierce County Herald</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
          jQuery(window).on('load', function() {
            googletag.pubads().refresh([window['weather_sponsorship']]);
          });
        </script>
      </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/piercecountyherald_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4543432-missing-person-white-bear-lake-police-ask-help-locating-teenager'>Missing person: White Bear Lake police ask for help locating teenager</a></li><li><a href='/news/government-and-politics/4543274-wisconsin-roundup-walker-take-action-lame-duck-bills-heavy'>Wisconsin roundup: Walker to take action on lame-duck bills; heavy drinking aside, Wis. is … pretty healthy?; more state news stories</a></li><li><a href='/news/education/4542272-plum-city-bestows-1st-quarter-honor-roll-designation'>Plum City bestows 1st quarter honor roll designation</a></li><li><a href='/news/4543062-ave-maria-academy-heart-christmas'>Ave Maria Academy: &#039;The Heart of Christmas&#039;</a></li><li><a href='/news/traffic-and-construction/4542802-wisdot-preparing-highway-29-construction'>WisDOT preparing for Highway 29 construction</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/tags/government" target="_self">government</a></li><li><a href="/news/education" target="_self">education</a></li><li><a href="/tags/business" target="_self">business</a></li><li><a href="/tags/politics" target="_self">politics</a></li><li><a href="/tags/region" target="_self">region</a></li><li><a href="/tags/accidents" target="_self">accidents</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/wrestling/4543431-wrestling-prescott-earns-first-dual-win-against-somerset-panthers-head'>Wrestling: Prescott earns first dual win against Somerset; Panthers head to Christmas Tournament</a></li><li><a href='/sports/basketball/4543419-girls-basketball-epc-completes-goals-loss-elk-mound'>Girls’ basketball: EPC completes goals in loss to Elk Mound</a></li><li><a href='/sports/basketball/4542276-boys-basketball-webb-posts-double-double-against-boyceville-spring-valley'>Boys&#039; basketball: Webb posts double-double against Boyceville; Spring Valley comes back from double-digit deficit</a></li><li><a href='/sports/wrestling/4542180-wrestling-sve-receives-seven-forfeits-clear-lake-dual'>Wrestling: SVE receives seven forfeits in Clear Lake dual</a></li><li><a href='/sports/basketball/4542147-girls-basketball-straub-has-career-night-panthers-loss-tigers'>Girls&#039; basketball: Straub has career night in Panthers&#039; loss to Tigers</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/ellsworth-panthers" target="_self">ellsworth panthers</a></li><li><a href="/tags/prescott-cardinals" target="_self">prescott cardinals</a></li><li><a href="/tags/spring-valley-cardinals" target="_self">spring valley cardinals</a></li><li><a href="/tags/high-school" target="_self">high school</a></li><li><a href="/tags/amateur" target="_self">amateur</a></li><li><a href="/sports/outdoors" target="_self">outdoors</a></li></ul></div></div></li><li class='leaf'><a href="/tags/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/community/events/4355035-old-school-vegas-prescott'>Old school Vegas in Prescott</a></li><li><a href='/entertainment/4353827-logue-presents-new-work-icelandic-textile-residency'>Logue presents new work from Icelandic textile residency</a></li><li><a href='/community/events/4352520-gallery-snowy-day-pumpkins'>Gallery: A snowy day for pumpkins</a></li><li><a href='/community/events/4351960-united-way-calls-grant-applications'>United Way calls for grant applications</a></li><li><a href='/lifestyle/health/4350254-health-briefs-community-conversation-gets-people-talking-about-mental'>Health briefs: Community Conversation gets people talking about mental health</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/food" target="_self">food</a></li><li><a href="/tags/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/tags/health" target="_self">health</a></li><li><a href="/tags/religion" target="_self">religion</a></li><li><a href="/tags/family" target="_self">family</a></li></ul></div></div></li><li class='leaf'><a href="/tags/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/community/legal-notices/4541482-town-isabelle-121718-town-board-meeting'>TOWN OF ISABELLE: 12/17/18 Town Board Meeting</a></li><li><a href='/community/legal-notices/4541479-pierce-county-121818-county-board-meeting-agenda'>PIERCE COUNTY: 12/18/18 County Board Meeting Agenda</a></li><li><a href='/community/legal-notices/4541485-pierce-co-highway-committee-121818-meeting-agenda'>PIERCE CO. HIGHWAY COMMITTEE: 12/18/18  Meeting Agenda</a></li><li><a href='/community/legal-notices/4541490-pierce-county-land-management-committee-121918-meeting-agenda'>PIERCE COUNTY LAND MANAGEMENT COMMITTEE: 12/19/18 Meeting Agenda</a></li><li><a href='/community/legal-notices/4541480-name-change-hearing-11019-case-no-18-cv-238'>NAME CHANGE HEARING: 1/10/19, Case No. 18-CV-238</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">Business</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend'>Prescott&#039;s Freedom Park turns 90 with celebration this weekend</a></li><li><a href='/business/announcements/4539477-prescott-chamber-seeks-award-nominations'>Prescott Chamber seeks award nominations</a></li><li><a href='/business/tourism/4541714-pierce-co-tourism-launches-research-project-grant'>Pierce Co. Tourism launches research project with grant</a></li><li><a href='/business/retail/4541245-what-about-those-gift-cards-billions-dollars-cards-go-unused'>What about those gift cards? Billions of dollars of cards go unused</a></li><li><a href='/business/tourism/4538051-octagon-house-opens-holiday-tour-season'>Octagon House opens for holiday tour season</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/business/announcements" target="_self">Announcements</a></li><li><a href="https://classifieds2.forumcomm.com/fcccontent/WFCategoryClassification.aspx" target="_self">Place a Business Announcement</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4543367-carol-halling'>Carol A. Halling</a></li><li><a href='/obituaries/4542358-mary-van-allen'>Mary Van Allen</a></li><li><a href='/obituaries/4543237-marie-t-glaus'>Marie T. Glaus</a></li><li><a href='/obituaries/4542778-james-leonard'>James A. Leonard</a></li><li><a href='/obituaries/4541317-james-s-jim-flanigan'>James S. &quot;Jim&quot; Flanigan</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/4534967-benjamin-charles-koehntop'>Benjamin Charles Koehntop</a></li><li><a href='/milestones/4511359-bill-and-jo-steele'>Bill and Jo Steele</a></li><li><a href='/milestones/4504525-mae-gilles'>Mae Gilles</a></li><li><a href='/milestones/4504524-bill-and-jo-steele'>Bill and Jo Steele</a></li><li><a href='/milestones/4504523-bob-barb-freiberg'>Bob &amp; Barb           Freiberg</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/new-arrivals" target="_self">new arrivals</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li><li><a href="/milestones/other-celebrations" target="_self">other celebrations</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/columns/4540096-column-winter-wont-stop-red-wing-bridge-project'>Column: Winter won&#039;t stop Red Wing Bridge project</a></li><li><a href='/opinion/4537645-petryk-column-wisconsins-future-looks-bright'>Petryk column: Wisconsin&#039;s future looks bright</a></li><li><a href='/opinion/letters/4537619-letters-editor-censorship-restricting-voters-will'>Letters to the editor: Censorship; Restricting voters&#039; will</a></li><li><a href='/opinion/columns/4537641-country-pastor-column-father-sending-his-son'>Country Pastor column: A Father sending His Son</a></li><li><a href='/opinion/columns/4537285-literally-lorna-column-time-year'>Literally Lorna column: This time of year</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="https://classifieds2.forumcomm.com/forumcele/WFCategoryClassification.aspx" target="_self">Submit a Political Letter</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="/basic-page/3729456-magazine-rack" target="_self">Magazine Rack</a></li><li class='leaf no-doormat'><a href="https://en.calameo.com/read/000735261b5431e192f08" target="_self">Real Estate Showcase</a><div class='doormat-menu'><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="https://www.rivertownlistings.com/" target="_self">Real Estate Showcase Ad Submission</a></li><li><a href="https://en.calameo.com/read/000735261b5431e192f08" target="_self">Real Estate Showcase current ads</a></li></ul></div></div></li><li class='leaf no-doormat'><a href="http://local.piercecountyherald.com/ads" target="_self">Print Ads</a></li><li class='leaf no-doormat'><a href="https://rivertownmultimedia.smugmug.com/PierceCountyHerald" target="_self">Buy Our Photos</a></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
          jQuery(window).ready(function() {
            refreshBid('top-leaderboard-ad', 'top_leaderboard_ad');
          });
        </script>
      </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="Business "> <meta itemprop='dateline' content="Red Wing,MN 55066"> <meta itemprop='articleBody' content="&lt;p&gt;Prescott's Dallas Eggers remembers relying on a handful of spots for a drink of water when he was a kid playing in the mid-'60s. There was the baseball diamond, the cemetery and what was then known as Tourist Park, now Freedom Park, which was only three blocks from his house.&lt;/p&gt;&lt;p&gt;&quot;That was our playground,&quot; Eggers said, now president of the Prescott chapter of the Pierce County Historical Association.&lt;/p&gt;&lt;p&gt;This year, the park that has acted as a playground and family hotspot for generations of Prescott residents like Eggers officially turned 90, and the Friends of the Freedom Park organization are hosting a &quot;birthday party&quot; to commemorate the day. The Dec. 15-16 event is pairing birthday cake with a feedback opportunity that will help guide the group's future programming at the park and the Great River Road Visitor and Learning Center, said the center's executive director Jessica Bierbrauer.&lt;/p&gt;&lt;p&gt;&quot;We're a new organization, but we try to incorporate a little bit of self-reflection into what we do,&quot; she said.&lt;/p&gt;&lt;p&gt;Throughout the park's 90 years (it's actually been a city-owned property for 100 years) the park has gone through several iterations, including a patriotic and symbolic name change in the 1980s from Tourist Park to Freedom Park.&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;Happy birthday, Freedom&lt;/p&gt;&lt;p&gt;Prescott originally received the land for Freedom Park from a local family in about 1918 and was officially founded in 1928, Eggers said. Without funding, it took 10 years to create the park, he said.&lt;/p&gt;&lt;p&gt;The park eventually received a renovation in the late 50s or early 60s, he said. The main park building burned down, and a new half-wall building was made with electricity, fireplaces and running water, Eggers said.&lt;/p&gt;&lt;p&gt;&quot;Some of the important things in town as a kid was where you could get a good drink of water,&quot; he said. &quot;So you always stopped by Tourist Park to get a drink.&quot;&lt;/p&gt;&lt;p&gt;In the years that followed the park mostly fell out of the community's priorities, he said. When the push to rename it Freedom Park and rehabilitate it came along, many residents thought it was still well kept-up. But Eggers said that wasn't the case.&lt;/p&gt;&lt;p&gt;&quot;A lot of people didn't want the development, but with anything you're either getting better or getting worse,&quot; he said. &quot;You get this fixation in your head of this is what it was.&quot;&lt;/p&gt;&lt;p&gt;In 1982, the city renamed the park Freedom Park, after a local bald eagle named Freedom became something of a local celebrity, Bierbrauer said. The eagle was injured and treated at the University of Minnesota, and at about the same time, several American hostages were released from Iran.&lt;/p&gt;&lt;p&gt;Freedom was flown to Washington D.C. for a commemorative event for the hostages and other Americans missing in action or who were prisoners, she said. Freedom later returned to Prescott and was released back into the wild.&lt;/p&gt;&lt;p&gt;In honor of the eagle and what it represented, the city elected to change the name to Freedom Park.&lt;/p&gt;&lt;p&gt;&quot;The eagle took on larger symbolism, you could say,&quot; Bierbrauer said.&lt;/p&gt;&lt;p&gt;Ever since the Great River Road Visitor and Learning Center broke ground near the park in 2006, the group has put on a variety of programming, Bierbrauer said. They vary from educational events for kids to some catered towards adults.&lt;/p&gt;&lt;p&gt;Paired with Prescott's location on the Mississippi and St. Croix rivers, and the wildlife that comes with it, the park can get a large number of visitors throughout the year. Bierbrauer said that about 15,000-16,000 or more people visit Freedom Park and the center every year.&lt;/p&gt;&lt;p&gt;&quot;We're 12 years old, we're always trying to do something better,&quot; Bierbrauer said. &quot;[The park] changes through the seasons; it's beautiful.&quot;&lt;/p&gt;&lt;p&gt;However, she knows there are numerous other ways for people to spend their time instead of at the park and participating in the center's programming.&lt;/p&gt;&lt;p&gt;With the planned birthday party coming up next weekend, she's hoping the cake can help prompt a conversation among attendees that leads to improved programming.&lt;/p&gt;&lt;p&gt;&quot;We're just hoping that people will stop in and enjoy some birthday cake, and enter in some conversations,&quot; Bierbrauer said.&lt;/p&gt;&lt;p&gt;Freedom Park's 90th birthday party will be held 10 a.m. to 5 p.m. Dec. 15 and noon to 5 p.m. Dec. 16. There will be cake, opportunities to give feedback on the park's programming and a 25 percent sale on gift shop items.&lt;/p&gt;&lt;p&gt;To learn more about the park, visit www.freedomparkwi.org.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Prescott's Freedom Park turns 90 with celebration this weekend"> <meta itemprop='author' content="David Clarey"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2018-12-14T12:00:00"> <meta itemprop='dateModified' content="2018-12-14T12:00:00"> <link itemprop='mainEntityOfPage' content="node/4541716"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="https://www.piercecountyherald.com/sites/default/files/styles/square_300/public/1idSbYhZrFsR3mEME452tFtyKetCgtFYH.jpg?itok=GF5VKYFA"> <meta itemprop="width" content="4000"> <meta itemprop="height" content="3000"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="David Clarey"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Prescott's Freedom Park turns 90 with celebration this weekend "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Red Wing"> <meta itemprop='addressRegion' content="MN"> <meta itemprop='streetAddress' content="2760 N Service Drive"> <meta itemprop='postalCode' content="55066"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
          jQuery(window).ready(function() {
            refreshBid('first-mobile-ad', 'first_mobile_ad');
          });
        </script>
        </div><h1 class='node-title'>Prescott's Freedom Park turns 90 with celebration this weekend</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/david-clarey'>David Clarey</a></span>
  <span class='node-byline-time'> Today  at 12:00 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'><img class='node-image large' src='https://www.piercecountyherald.com/sites/default/files/styles/16x9_620/public/1idSbYhZrFsR3mEME452tFtyKetCgtFYH.jpg?itok=LUYgoSzr' data-featherlight='https://www.piercecountyherald.com/sites/default/files/styles/full_1000/public/1idSbYhZrFsR3mEME452tFtyKetCgtFYH.jpg?itok=hRAUz4TN'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption image-caption-display'>A drone shot from Dallas Eggers shows a birds-eye view of the Freedom Park and the Great River Road Visitor &amp; Learning Center in Prescott. Photo courtesy of Dallas Eggers. </span><span class='slide-number'>1 / 2</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='https://www.piercecountyherald.com/sites/default/files/styles/16x9_620/public/1RWvS3M1zxpqUFK3zn-HDFnLwrjbR0RYS.jpg?itok=apoaZYUx' data-featherlight='https://www.piercecountyherald.com/sites/default/files/styles/full_1000/public/1RWvS3M1zxpqUFK3zn-HDFnLwrjbR0RYS.jpg?itok=4PhPzOdn'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption image-caption-display'>An archival photo of what was then known as Tourist Park, now Freedom Park, in Prescott along the Great River Road. Photo courtesy of Dallas Eggers, Pierce County Historical Association.</span><span class='slide-number'>2 / 2</span></div></div><div class='node-body'><p>Prescott's Dallas Eggers remembers relying on a handful of spots for a drink of water when he was a kid playing in the mid-'60s. There was the baseball diamond, the cemetery and what was then known as Tourist Park, now Freedom Park, which was only three blocks from his house.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
          jQuery(window).ready(function() {
            refreshBid('second-mobile-ad', 'second_mobile_ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_rxoa3s6yarzfyvoyhg4glhyota' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>"That was our playground," Eggers said, now president of the Prescott chapter of the Pierce County Historical Association.</p><p>This year, the park that has acted as a playground and family hotspot for generations of Prescott residents like Eggers officially turned 90, and the Friends of the Freedom Park organization are hosting a "birthday party" to commemorate the day. The Dec. 15-16 event is pairing birthday cake with a feedback opportunity that will help guide the group's future programming at the park and the Great River Road Visitor and Learning Center, said the center's executive director Jessica Bierbrauer.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>"We're a new organization, but we try to incorporate a little bit of self-reflection into what we do," she said.</p><p>Throughout the park's 90 years (it's actually been a city-owned property for 100 years) the park has gone through several iterations, including a patriotic and symbolic name change in the 1980s from Tourist Park to Freedom Park.</p><p class="subhead">Happy birthday, Freedom</p><p>Prescott originally received the land for Freedom Park from a local family in about 1918 and was officially founded in 1928, Eggers said. Without funding, it took 10 years to create the park, he said.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>The park eventually received a renovation in the late 50s or early 60s, he said. The main park building burned down, and a new half-wall building was made with electricity, fireplaces and running water, Eggers said.</p><p>"Some of the important things in town as a kid was where you could get a good drink of water," he said. "So you always stopped by Tourist Park to get a drink."</p><p>In the years that followed the park mostly fell out of the community's priorities, he said. When the push to rename it Freedom Park and rehabilitate it came along, many residents thought it was still well kept-up. But Eggers said that wasn't the case.</p><p>"A lot of people didn't want the development, but with anything you're either getting better or getting worse," he said. "You get this fixation in your head of this is what it was."</p><p>In 1982, the city renamed the park Freedom Park, after a local bald eagle named Freedom became something of a local celebrity, Bierbrauer said. The eagle was injured and treated at the University of Minnesota, and at about the same time, several American hostages were released from Iran.</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><div id='mid-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('mid-leaderboard-ad');
          });
          jQuery(window).ready(function() {
            refreshBid('mid-leaderboard-ad', 'mid_leaderboard_ad');
          });
        </script>
        </div><p>Freedom was flown to Washington D.C. for a commemorative event for the hostages and other Americans missing in action or who were prisoners, she said. Freedom later returned to Prescott and was released back into the wild.</p><p>In honor of the eagle and what it represented, the city elected to change the name to Freedom Park.</p><p>"The eagle took on larger symbolism, you could say," Bierbrauer said.</p><p>Ever since the Great River Road Visitor and Learning Center broke ground near the park in 2006, the group has put on a variety of programming, Bierbrauer said. They vary from educational events for kids to some catered towards adults.</p><p>Paired with Prescott's location on the Mississippi and St. Croix rivers, and the wildlife that comes with it, the park can get a large number of visitors throughout the year. Bierbrauer said that about 15,000-16,000 or more people visit Freedom Park and the center every year.</p><p>"We're 12 years old, we're always trying to do something better," Bierbrauer said. "[The park] changes through the seasons; it's beautiful."</p><p>However, she knows there are numerous other ways for people to spend their time instead of at the park and participating in the center's programming.</p><p>With the planned birthday party coming up next weekend, she's hoping the cake can help prompt a conversation among attendees that leads to improved programming.</p><p>"We're just hoping that people will stop in and enjoy some birthday cake, and enter in some conversations," Bierbrauer said.</p><p>Freedom Park's 90th birthday party will be held 10 a.m. to 5 p.m. Dec. 15 and noon to 5 p.m. Dec. 16. There will be cake, opportunities to give feedback on the park's programming and a 25 percent sale on gift shop items.</p><p>To learn more about the park, visit <a href="http://www.freedomparkwi.org">www.freedomparkwi.org</a>.</p></div><div style='clear:both;'></div><script type='text/javascript'>
							ga('send','event','Recommended','view','recommended-view');
							ga('combinedSites.send','event','Recommended','view','recommended-view');
						</script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><div class='recommended node-ad-desktop nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by Pierce County Herald</div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4538306"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/1XI5ZI1ZpDzP0B81J71pOB8cxQw79_fTb.jpg?itok=xxDy6-gT" alt="In 2017, Pierce County Investigator Pete Koch was one of the many law enforcement officers that volunteered his time during Shop With A Cop. File photo" title="In 2017, Pierce County Investigator Pete Koch was one of the many law enforcement officers that volunteered his time during Shop With A Cop. File photo" />Shop with a Cop in its fourth year</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4538069"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/17IE-bbMozyRRO_DxzwNm6p-WIg7quVaM.jpg?itok=Y7TBd3QO" alt="Steven B. Bettinger" title="Steven B. Bettinger" />N.C. man charged in St. Croix County online sex sting</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4531256"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/field/image/Pierce%20County%20Courthouse%20smaller_8.jpg?itok=f27xzAmx" alt="" />Pierce County Circuit Court briefs</a></div></div><script type='text/javascript'>
					jQuery('.recommended.node-ad-desktop a').on('click', function() {
						ga('send', 'event', 'Recommended', 'click', 'recommended-click');
						ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
					});
				</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-desktop a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-desktop a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by Pierce County Herald</div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4538306"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/1XI5ZI1ZpDzP0B81J71pOB8cxQw79_fTb.jpg?itok=xxDy6-gT" alt="In 2017, Pierce County Investigator Pete Koch was one of the many law enforcement officers that volunteered his time during Shop With A Cop. File photo" title="In 2017, Pierce County Investigator Pete Koch was one of the many law enforcement officers that volunteered his time during Shop With A Cop. File photo" />Shop with a Cop in its fourth year</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4538069"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/17IE-bbMozyRRO_DxzwNm6p-WIg7quVaM.jpg?itok=Y7TBd3QO" alt="Steven B. Bettinger" title="Steven B. Bettinger" />N.C. man charged in St. Croix County online sex sting</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="//www.piercecountyherald.com/node/4531256"><img src="https://www.piercecountyherald.com/sites/default/files/styles/16x9_315/public/field/image/Pierce%20County%20Courthouse%20smaller_8.jpg?itok=f27xzAmx" alt="" />Pierce County Circuit Court briefs</a></div></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad-container'>
        <div id='third-mobile-ad' class='mobile-ad'>
          <script type='text/javascript'>
            googletag.cmd.push(function() {
              googletag.display('third-mobile-ad');
            });
            // Pass in the slot name for the ad
            jQuery(window).on('load', function() {
              jQuery('#third-mobile-ad-container').lazyload('third-mobile-ad');
            });
          </script>
          </div>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='//www.piercecountyherald.com/taxonomy/term/3127'>Business</a><a class='topic category' href='//www.piercecountyherald.com/taxonomy/term/312651'>Tourism</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/1146'>Features</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/2448'>News</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/28951'>prescott</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/63845'>Freedom Park</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/40435'>pierce county historical association</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/1520'>History</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/4808'>Eagles</a><a class='topic tag' href='//www.piercecountyherald.com/taxonomy/term/13696'>United States</a></div><div id='ad-content-distribution'></div><div id='fourth-mobile-ad-container'>
        <div id='fourth-mobile-ad' class='mobile-ad'>
          <script type='text/javascript'>
            googletag.cmd.push(function() {
              googletag.display('fourth-mobile-ad');
            });
            // Pass in the slot name for the ad
            jQuery(window).on('load', function() {
              jQuery('#fourth-mobile-ad-container').lazyload('fourth-mobile-ad');
            });
          </script>
          </div>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',23);
  ga('send', 'event', 'article', 'paragraphs', '23');
  ga('send', 'event', 'article', 'length', 'characters',4520);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',21349);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',23);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '23');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',4520);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',21349);
</script>
    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-origami-ad block-fcc-advertising-origami-ad odd block-without-title" id="block-fcc-advertising-origami-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="origami-ad-container"></div>

  <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="86440640-3471-4f28-83e3-769516c0eef0">
  </script>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad even block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='first-sidebar-ad-container'>
        <div id='first-sidebar-ad'>
          <script>
            googletag.cmd.push(function() {
              googletag.display('first-sidebar-ad');
            });
            jQuery(window).ready(function() {
              refreshBid('first-sidebar-ad', 'first_sidebar_ad');
            });
          </script>
        </div>
      </div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest odd block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4543432-missing-person-white-bear-lake-police-ask-help-locating-teenager">Missing person: White Bear Lake police ask for help locating teenager<span class='latest-date'>1 hour ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/wrestling/4543431-wrestling-prescott-earns-first-dual-win-against-somerset-panthers-head">Wrestling: Prescott earns first dual win against Somerset; Panthers head to Christmas Tournament<span class='latest-date'>1 hour ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/basketball/4543419-girls-basketball-epc-completes-goals-loss-elk-mound">Girls’ basketball: EPC completes goals in loss to Elk Mound<span class='latest-date'>2 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/business/tourism/4541716-prescotts-freedom-park-turns-90-celebration-weekend">Prescott's Freedom Park turns 90 with celebration this weekend<span class='latest-date'>5 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/government-and-politics/4543274-wisconsin-roundup-walker-take-action-lame-duck-bills-heavy">Wisconsin roundup: Walker to take action on lame-duck bills; heavy drinking aside, Wis. is … pretty healthy?; more state news stories<span class='latest-date'>7 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-5">
        <div class="space-eater-headline class-14px"><a href="/news/education/4542272-plum-city-bestows-1st-quarter-honor-roll-designation">Plum City bestows 1st quarter honor roll designation<span class='latest-date'>10 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-6">
        <div class="space-eater-headline class-14px"><a href="/news/4543062-ave-maria-academy-heart-christmas">Ave Maria Academy: 'The Heart of Christmas'<span class='latest-date'>22 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-7">
        <div class="space-eater-headline class-14px"><a href="/news/traffic-and-construction/4542802-wisdot-preparing-highway-29-construction">WisDOT preparing for Highway 29 construction<span class='latest-date'>1 day ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget odd block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <script>
jQuery(document).ready(function() {
  // This will fire when document is ready:
  jQuery(window).resize(function() {
      // This will fire each time the window is resized:
    
      if(jQuery(window).width() < 480) {
        if(jQuery('#origami_mobile_widget').is(':empty')){
          var script = document.createElement("script");
          script.setAttribute("charset", "UTF-8");
          script.setAttribute("src", "https://origami.secure.ownlocal.com/origami-widget.js");
          script.setAttribute("id", "origami-ad-widget");
          script.setAttribute("data-partner-id", "86440640-3471-4f28-83e3-769516c0eef0");
          script.setAttribute("data-ad-container-ids", "origami-ad-container2");
          script.setAttribute("type", "text/javascript");
          var head = document.getElementsByTagName("head")[0];
          head.appendChild(script);
          var origami = jQuery('<div></div>').attr("id", "origami-ad-container2");
          jQuery('#origami_mobile_widget').append(origami);
        }
      }
      else{ 
        jQuery('#origami_mobile_widget').empty();
      }
  }).resize(); // This will simulate a resize to trigger the initial run.
});
</script>
<div id="origami_mobile_widget" style="width: 300px; margin: 30px auto 10px;"></div>


<div id='bottom-leaderboard-ad-container'>
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
              googletag.display('bottom-leaderboard-ad');
          });
          // Pass in the slot name for the ad
          jQuery(window).on('load', function() {
            jQuery('#bottom-leaderboard-ad-container').lazyload('bottom-leaderboard-ad');
          });
        </script>
      </div>
    </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=RPC' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/piercecountyherald" title="">Subscribe to the Paper</a></li><li><a href="https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login2.hmtl?siteid=RPCE&authonly=yes&AuthControlID=RPC" title="Access E-Paper">Access E-Paper</a></li>      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="mailto:customerservice+piercecountyherald.com@forumcomm.com" title="">Get Website Help</a></li>
      <li><a href="http://www.forumcomm.com/careers/" title="">Work With Us</a></li>
    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="//www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="//www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="//www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="//impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/piercecounty" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/pages/Pierce-County-Herald/138576996175305" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Pierce County Herald</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Pierce County Herald</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">2760 N Service Drive</div>
      <span class="locality">Red Wing</span>, 
      <span class="region">MN</span> 
      <span class="postal-code">55066</span>
    </div>

    Call us at <div class="tel">800-535-1660</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php" style="display: none;">randomness</a></div>  </div>
</div><script type="text/javascript" defer="defer" src="https://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="https://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?pjn6cr"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?pjn6cr"></script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?pjn6cr"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?pjn6cr"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?pjn6cr"></script>
<script type="text/javascript" src="https://www.piercecountyherald.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>

    <div id='in-page-ad'>
          <script>
            googletag.cmd.push(function() {
              googletag.display('in-page-ad');
            });
              jQuery(window).on('load', function() {
                googletag.pubads().refresh([window['in_page_ad']]);
              });
          </script>
        </div>  </body>
</html>
